CDN Cache Invalidation Delay

Minor Resolved

Started Feb 12, 2026 at 07:44 UTC

Resolved Feb 12, 2026 at 09:44 UTC

Static assets were not updating properly due to cache invalidation delays.

Affected Components

CDN

Timeline

Resolved Feb 12, 2026 at 09:44 UTC

Cache has been manually purged and the CDN configuration has been updated to improve invalidation speed.

Investigating Feb 12, 2026 at 07:44 UTC

We are investigating reports of outdated content being served to some users.

Incident Created Feb 12, 2026 at 07:44 UTC

Static assets were not updating properly due to cache invalidation delays.